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Microsoft Excel 2016: Part 2  
Modifying and Formatting Cells 

& Basics on Worksheets 

 
 
 

Flash Fill:  
A new feature since Excel 2013, Flash Fill can enter 

data automatically into your worksheet, saving you 

a lot of time and effort. Just like the fill handle, Flash 

Fill can guess what kind of information you're 

entering into your worksheet. Flash Fill is on by 

default and automatically fills your data when it 

senses a pattern. However, if it’s not working as 

expected, here’s how you can check if Flash Fill is 

turned on. 

1. Click File>Options. 

2. Click Advanced and make sure the 

Automatically Flash Fill box is checked. 

 

 

If your data has many inconsistencies, automatic Flash Fill may not appear though you selected the options 

explained above.  In this case, you can manually activate Flash Fill by using Data>Flash Fill in the Data 

Tools Group OR using Control + E combination.  You can always use the old feature, Text to Columns to 

split text into different cells (This feature will be covered in Level 5).  In the exercise below, instead of using 

Text to Columns feature to split the data, we'll use Flash Fill to create a list of first names using a list of 

existing email addresses.  

Exercise:  Open FlashFillExample worksheet in the same workbook ExcelPart2.xlsx.   

 Select Cell C5 and type in the first name “Josie” in the cell.  Note: Flash Fill is case sensitive. If you 

enter a lower-case last name, for example, all the first names follow suit. 

 Select Cell C6 and as soon as you start with the letter “W” to type the next first name “Wendy”, the 

Flash Fill preview will appear below the selected cell whenever Flash Fill is available. 

 Just hit Enter to accept the data to be added to the 

worksheet. 

 Note:  To modify or undo Flash Fill, click the Flash Fill 

button next to recently added Flash Fill data. 

 Save the workbook and close it. 

 

 

http://office.microsoft.com/client/15/help/preview?AssetId=HA102809804&lcid=1033&NS=EXCEL&Version=15&tl=2&CTT=5&origin=HA102809794
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Find and Replace 
This feature helps you save time to locate specific information when working with a lot of data in Excel. 

You can easily search your workbook using the Find feature, which allows you to find the data and also 

modify content using the Replace feature. 

Exercise to find content: 

 From workbook ExcelPart2.xlsx, select FlashFillExample worksheet.   

 From the Home tab, click the Find and Select command, then 

select Find... from the drop-down menu. (Note:  You can also access 

the Find command by pressing Ctrl+F on your keyboard.) 

 The Find and Replace dialog box will appear. Enter the content you 

wish to find. In our example, type in an employee’s last name “knight”. 

 Click Find Next to find further instances or Find All to see every instance of the search term. 

 

 

 

 

 

 

 

 

 

 

 When you are finished, click Close to exit the Find and Replace dialog box. 

Exercise to replace content: 

 In the same workbook, from the Home tab, click the Find and Select command, then 

select Replace... from the drop-down menu. (Note:  You can also access the Replace command 

by pressing Ctrl+H on your keyboard.) 

 The Find and Replace dialog box will appear.  

 Type the text you wish to find in the Find what: field.  Type “com”. 

 Type the text you wish to replace it with in the Replace with: field.  Type “net” then click Find 

Next.  

 If the content is found, the cell containing that content will be selected. 

 Review the text to make sure you want to replace it. 
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 If you wish to replace it, select one of the replace options: 

o Replace will replace individual instances. 

o Replace All will replace every instance of the text throughout the workbook. In our 

example, we'll choose this option to save time. 

 A dialog box will appear, confirming the number of replacements made. Click OK to continue.  

 

 
 

 The selected cell content will be replaced.  When you are finished, click Close to exit the Find 

and Replace dialog box. 

 

Fit the Data Without Resizing Column: 

Add a new worksheet by clicking on the plus sign to work on this concept.  

You can fit the data in a cell without resizing the width of a column by using 

the Wrap Text command in the Alignment Group under the Home Tab.   

Use this command before or after entering data and the cell height will be 

automatically adjusted to accommodate the current cell width. 

OR 

You can use the keystroke combination Alt + Enter when you reach the end of the cell and you want to 

force the cursor to create another line within the same cell.  Note: Click the Wrap Text command again 

to unwrap the text. 
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1. Enter the data shown in Cells A1:B7.  See right.  Do not 
worry about content not fitting in the column yet.  Use 
tab key to enter data across the row and then hit Enter 
key to move your selected cell to the cell below.  Select 
the entire column A.  Click on the Wrap Text command 

 in the Alignment group.  See all cells with longer 
texts now rearranged to fit cell contents on two lines in 
same cell. 

2. Let’s make all the columns width 19.  Select the entire 
worksheet. Resize the column width to 19 by using Home>Format>Column Width.  Now each 
cell has enough space to fit its contents.  Still have the entire worksheet selected. 

3. Let’s make Excel fit all contents in each column just right (not too wide or narrow).  Double-
click between any two columns and any two rows to let Excel do the work for you.   

4. Finally, click in any cell to de-select the entire worksheet. 

5. Leave the workbook open. 
 

To merge cells using the Merge & Center command: 
Cells can be merged in order to create larger cell areas – to create a title cell for the entire table, for 

example. 

Exercise:   

 Use the same worksheet already 

opened above. 

 Insert a new row above the heading 

row 1.  (Hint: Select the entire row 1 

and select Insert from the Cells group 

under the Home tab.) 

 Type in “MONTHLY EXPENSES” in Cell 

A1. 

 Select the cell range you want to merge together. (Cells A1:B1)  

 Select the Merge & Center command on the Home tab.   

 The selected cells will be merged, and the text will be centered.  

Re-adjust the row height on row 1.  

 

 

 

 

Other Merge Options: 

 Merge & Center: Merges the selected cells into one cell and centers the text. 

 Merge Across: Merges the selected cells into larger cells while keeping each row separate. 

 Merge Cells: Merges the selected cells into one cell, but does not center the text. 

 Unmerge Cells: Unmerges selected cells. 
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Formatting Cells 
Use Excel Formatting commands to draw attention to specific sections of your workbook and make your 

text easier to view and understand.  You may also apply number formatting to tell Excel exactly what 

type of data you’re using in the workbook, such as percentages (%), currency ($), and so on.  You can 

find all formatting commands under the Home tab: Font Group, Alignment Group, Number Group, and 

Styles Group.  

 

Exercise: Use FormattingCellsExample worksheet from same workbook and follow instructions. 

To change the font: 
Excel provides a variety of other fonts you can use to customize your cell text though the default font is 

Calibri. In the example below, we'll format our title cell to help distinguish it from the rest of the 

worksheet. 

1. Select the cell(s) you wish to 

modify. Select the merged 

cells D1 through G1 for our 

practice. 

 

 

2. Click the drop-down arrow next to 

the Font command on the Home 

tab. The Font drop-down menu will 

appear.  

3. Select the desired font. A live 

preview of the new font will appear 

as you hover the mouse over 

different options. In our example, 

we'll choose Elephant.  The text 

will change to the selected font. 

 



Copyright © 2020 ASCPL All Rights Reserved  Page 6 of 16 MS2016-ExcelPart2 MMS 9/1/2020 
 

To change the font size: 
1. Select the same merged title cell you selected above. 

2. Click the drop-down arrow next to the Font Size 

command on the Home tab. The Font Size drop-down 

menu will appear.   

3. Select the desired font size. A live preview of the new 

font size will appear as you hover the mouse over 

different options. In our example, we will choose 14 to 

make the text larger. 

Note:  You can also use Increase or Decrease font size command by click on either command.   

 

To change the font color: 
1. Select the same merged title cell you selected 

above. 

2. Click the drop-down arrow next to the Font Color 

command on the Home tab. The Color menu will 

appear. 

3. Select the desired font color. A live preview of the 

new font color will appear as you hover the mouse 

over different options. In our example, we'll choose 

Purple. 

4. The text will change to the selected font color. 

Note:  You can also select More Colors at the bottom of 

the menu to access additional color options.  
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To use the Bold, Italic, and Underline commands: 
1. Select the same merged title cell you selected above.  

2. Click the Bold (B), Italic (I), or Underline (U) command on the Home 

tab. In our example, we'll make the selected cells bold to look like 

below. 

 

 

 

Note:  You can also press Ctrl+B on your keyboard to make selected text bold, Ctrl+I to apply italics, 

and Ctrl+U to apply an underline.  These commands are Toggle Buttons which means click to turn 

them on and click it again to turn them off. 

 

Text alignment 
By default, any text entered into your worksheet will be aligned to the bottom-left of a cell. Any 

numbers will be aligned to the bottom-right of a cell. Changing the alignment of your cell content allows 

you to choose how the content is displayed in any cell, which can make your cell content easier to read. 

 

  Vertical Text Alignment Buttons. (Top, Center, and Bottom) 

      Horizontal Text Alignment Buttons (Left, Center, and Right) 

 

1. Select the same merged title cell you selected above.  

2. Practice alignment by using the Horizontal Center Alignment button to make the title 

horizontally centered.  

3. Next, use the Vertical Center Alignment button to make the title vertically centered.  
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Other Alignment Options: 

Orientation: You can rotate your text diagonally or vertically to label narrow columns by using this 

function. 

Exercise: Continue using the same worksheet opened above. 

1. Expand the height of the Row 2 up to about 90 pixels as shown.  

 

2. Select Cells D2 through G2. 

3. Click the drop-down arrow from the Orientation button 

under the Home tab and select any of the orientation 

style to test.  If you do not like the result, click on the 

same style to turn it off and the text should go back to 

horizontal style. 

 

Indentation:  Use this function to move the content further away or closer to the Cell border. 

Select a few cells under the Starting or Ending header columns.  Use either 

decrease or increase indentation buttons to test.  

 

Cell borders and fill colors 
Cell borders and fill colors allow you to create clear and defined boundaries for different sections of 

your worksheet. In our examples below, we'll add cell borders and fill color to our merged title cell to 

help distinguish them from the rest of the worksheet. 

To add a border: 

1. Select the same merged title 

cell you selected above.   

2. Click the drop-down arrow 

next to the Borders 

command on the Home tab. 

The Borders drop-down 

menu will appear. 

3. Select the border style you 

want to use. In our example, 

we will choose to display 

Thick Box Border. 

4. The selected border style will appear. 
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Note:  You can draw borders and change the line style and color of borders with the Draw Borders 

tools at the bottom of the Borders drop-down menu. Once you have selected your desired color and 

style of your border, your mouse will turn into a drawing pencil mode.  You can point and click on 

mutiple cells to draw a border or click on each cell border to draw border of each cell. Turn off the 

draw border function by clicking on Borders command on the Home tab. 

 

To add a fill color: 

1. Select the same merged 

title cell you selected 

above. 

2. Click the drop-down arrow 

next to the Fill Color 

command on the Home 

tab. The Fill Color menu will 

appear. 

3. Select the fill color you 

want to use. A live preview 

of the new fill color will appear as you hover the mouse over different options. In our example, 

we'll choose Light Blue.  

 

Cell styles 
Rather than formatting cells manually, you can use Excel's predesigned cell styles. Cell styles are 

a quick way to include professional formatting for different parts of your workbook, such 

as titles and headers. 

1. Select the cells with headers in 

them: Date, Starting, Ending, Miles.  

2. Click the Cell Styles command on 

the Home tab, then choose the 

desired style from the drop-down 

menu. In our example, we'll choose 

Accent 1. 

3. The selected cell style will appear. 

4. Select Cells D3 through G13 and 

apply the Note Cell Style.  

Note:  Applying a cell style will replace any 

existing cell formatting except for text 

alignment. You may not want to use cell 

styles if you've already added a lot of 

formatting to your workbook. 
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Formatting text and numbers 
In Excel, you can apply specific formatting for text and numbers instead of 

displaying all cell content in exactly the same way.  Use formatting to 

change the appearance of dates, times, decimals, percentages (%), currency 

($), etc. 

To apply number formatting: 

We will use same FormattingCellsExample worksheet.  We'll change the 

number format for the cells to modify the way dates are displayed. 

1. Select the entire Column D to modify. 

2. Click the drop-down arrow next to the Number Format command 

on the Home tab. The Number Formatting drop-down menu will 

appear. 

3. Select the desired formatting option. In our example, we will 

change the formatting to Long Date. The selected cells will change 

to the new formatting style.  In our example, the width of Column D is not wide enough to fit 

the style of the format as the Error values ###### appear in every cell in that column.  Just 

simply adjust the width of the column D and now you should see the content of the cells in the 

new formatting style – Long Date. 
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Other Number Formatting:  

General: It is the default format for any cell. When you enter a number into 

the cell, Excel will guess the number format that is most appropriate. If you 

enter "1-5", the cell will display the number as a Short Date, "1/5/Year" (year 

representing the current year in 4 digits such as 2014). 

Number: Formats numbers with decimal places. If you enter "4" into the cell, 

the cell will display the number as "4.00".  For our practice, select Cells G3 

through G11, change the range into Number format to see the mileage 

figures to show in two decimal points. 

Currency: Formats numbers as currency with a currency symbol.  If you enter 

"4" into the cell, the cell will display the number as "$4.00".  For our practice, 

select Cell G13 and change the format to Currency. 

Accounting: Formats numbers as monetary values like the Currency format, 

but it also aligns currency symbols and decimal places within columns.  This 

format makes it easier to read long lists of currency figures. 

Short Date: Formats numbers as M/D/YYYY.  August 8th, 2013 would be 

"8/8/2013". 

Long Date: Formats numbers as Weekday, Month DD, YYYY.  7/28/14 will be 

“Monday, July 28, 2014". 

Time: Formats numbers as HH/MM/SS and notes AM or PM.  For example, "10:25:00 AM".  You must 

enter PM or else all time without AM or PM will default to AM. 

Percentage:  Formats numbers with decimal places and the percent sign. If you enter "0.75" into the 

cell, the cell will display the number as "75.00%". 

Fraction:  Formats numbers as fractions separated by the forward slash.  For example, if you enter "1/4" 

into the cell formatted as Fraction, the cell will display the number as "1/4". If you enter "1/4" into a cell 

that is formatted as General, the cell will display the number as a date, "4-Jan". Note: Format the cells 

to show Fraction first before entering the data. 

Scientific:  Formats numbers in scientific notation.  For example, if you enter more than 11 digit 

numbers such as “140000000000" into the cell, then the cell will display the number as "1.40E+11".  

Note: by default, Excel will format the cell in scientific notation if it contains a large integer. If you do not 

want Excel to format large integers with scientific notation, use the Number format. 

Text:  Formats numbers as text, meaning that what you enter into the cell will appear exactly as it was 

entered.  Text is left-aligned while numbers are right-aligned by default.  If a cell contains both text and 

numbers Excel defaults to left-aligned. 

More Number Formats:  Clicking on this will open up the Format Cells dialogue box with the Number 

tab where you can find more specific style of each format style explained above. 

Your finished spreadsheet should look like the one shown on next page. Save and close the workbook. 
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Menu Version on Formatting Cells: 
You can perform all of the formatting examples we went through above by using Menu Version of those 

commands rather than shortcuts on the Ribbon we used.  A few extra commands not available on the 

Ribbon could be found here.  Regardless of from which group on the Home tab: Font, Alignment, or 

Number you launch a dialogue box, the Format Cells dialogue box will open.  Once it opens, you can 

freely click on other tabs to get to a particular command.  See below. 
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Worksheets 
Every workbook should begin with at least one worksheet in it which by default named as Sheet1.  A 

workbook can contain multiple worksheets.  As you build your workbook, you may like to add, delete or 

rename your worksheets or re-arrange the worksheet locations.   

Exercise:  Open WorksheetPractice.xlsx to practice.  [Example from gcflearnfree.org] 

Renaming Worksheets 
We will rename the worksheets to organize the worksheets by months.  

1. Right-click the Sheet1 and select rename from the menu.  

2. Type in January.  

3. Click anywhere outside of the worksheet, or press Enter on your 

keyboard. The worksheet will be renamed. 

4. Alternatively, you can double-click and rename a worksheet.  

Double-click on Sheet2. The name Sheet2 will be highlighted. Then 

type in February.  Do the same for Sheet3 renaming as March. 

 

Adding and Deleting Worksheets 

Simply click on the plus sign “+” at the end of all worksheets to add a new worksheet.   

You may also use Insert from the right-click menu to insert a new worksheet.  

Doing so will add a new worksheet in front of the sheet you right-clicked. 

To delete a worksheet, right-click on the sheet to be deleted.  Select Delete from 

the menu.  

Note: You can change the default number of worksheets when creating new 

workbooks.  Go to the Backstage view under File>Options and change the 

number of worksheets in section that says “When creating new workbooks”. 
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Copy a Worksheet: 
You can duplicate the content of a worksheet by using “Copy” function in Excel. 

1. Right-click the worksheet you want to copy, then select Move or Copy from the worksheet 

menu. 

2. The Move or Copy dialog box will appear. Choose where the sheet will appear in the Before 

sheet: field. In our example, we'll choose (move to end) to place the worksheet to the right of 

the existing worksheet. 

3. Check the box next to Create a copy, then click OK.  The worksheet will be added at the end of 

existing worksheets; given the same name with a new version number in parenthesis.  You may 

rename the sheet as April.   

   
  

4. If you desire to move or copy a worksheet to an entirely different workbook, click on the drop-

down arrow next to the section To book: and select (new book) or select any other workbook 

shown in the box.  Be sure to check the “Create a copy” box if you are copying the worksheet. 
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Move a Worksheet: 
1. Select the worksheet you wish to move. The cursor will become a small worksheet icon Mouse 

change.  

2. Hold and drag the mouse until a small 

black arrow Mouse change appears 

above the desired location.  

 

3. Release the mouse. The worksheet will 

be moved.  

 

 

 

Change the worksheet color: 
You can change a worksheet's color to help organize your worksheets. 

1. Right-click the desired worksheet, and hover the mouse over Tab Color. The Color menu will 

appear. 

2. Select the desired color. A live preview 

of the new worksheet color will appear 

as you hover the mouse over different 

options. In our example, we'll choose 

Green.  

 

3. The worksheet color will be changed.  

Note: The worksheet color is less 

noticeable when the worksheet is 

selected.  However, once you select 

another worksheet, the color will appear 

more distinctively.  See below. 
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Grouping and ungrouping worksheets: 
When you work with multiple worksheets at the same time, worksheets can be combined together into 

a group. Any changes made to one worksheet in a group will be made to every worksheet in the group. 

Exercise: Let’s use the same workbook WorksheetPractice.xlsx and practice the following steps. 

Grouping non-adjacent worksheets: 

 Select the first worksheet January 

 Hold down the Control button on your keyboard and select the 

last worksheet April; let go off your Control button 

 You will notice the word [Group] appears next to the title of the 

workbook on top of screen 

 
 Now the January and April worksheets are selected, anything 

you change on January sheet will appear on the April sheet.   

 Click Cell A1 and use Cell color fill to change to green color in 

that cell.  Now Cell A1 should have the same color on both 

January and April worksheets. 

 To ungroup those two sheets, you can either right-click on one 

of those two sheets and select Ungroup Sheets or just click on another sheet that was not in the 

original group.  

 

Grouping adjacent worksheets: 

 Select the first worksheet January 

 Hold down the Shift button and select the last worksheet April and let go off your shift 

button 

 Now all the sheets are selected anything you change on one sheet will appear on all other 

selected sheets   

 Select Cells A2:D2 (A2 through D2) and change the text color to Red. 

 All the cell blocks A2:D2 on all sheets will now have text with font color red.   

 Click on any sheets that was not chosen first to group or use Ungroup Sheets command 

from the menu by right-clicking on any sheet.  OR 

If you had chosen all worksheets from the beginning to the end by using the shift key, then you can click 

on the last sheet or any other sheet you did not select in the first place to ungroup. 


