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Microsoft Excel 2016: Part 6  

Creating Custom Lists 

Fill Command, Tables And 

Introduction to Charts 

 

 

 

Create and Fill New Custom Lists: 

There are only four kinds of built-in custom list: the day of week and the month of year. That means you 

can enter any value from the lists and make Excel to fill in the rest by using the Auto Fill or Fill Handle 

function.  

 

Built-in Custom List 

Sun, Mon, Tue, Wed, Thu, Fri, Sat 

Sunday, Monday, Tuesday, Wednesday, Friday, Saturday 

Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec 

January, February, March, April, May, June, July, August, September, October, November, December 

 

Open a new worksheet by clicking on the + sign at the end in the ExcelPart6.xlsx workbook to practice this 

concept.   

 

 In Cell A1, type in “June” as a month. Hit Enter to complete the data.  Select Cell A1 again. 

 Use Fill Handle in Cell A1 and drag it all the way to Cell A16.  Notice how the remaining months got 

filled in and entries on months restart from January after December. 

 

Sometimes you may use some specific contents for many times in Excel, but without using the custom list 

you may have to reenter it over and over 

again. To avoid that you can create a 

custom list of these contents in Excel, 

and then you can quickly use the custom 

list at any time in Excel without retyping 

the same contents again.  Let’s say you 

want to create a custom list of names. 

 

You can do it with following steps: 

 Click File>Options 

 In the Excel Options dialog box, 

click Advanced button at left bar, 

scroll to the General section and 

click the Edit Custom List button. 

See image on right. 
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 Now you get into the Custom Lists dialog box. Select the NEW LIST item in the Custom lists: box. 

And two ways to create new list: 

1. You can type the custom list of values in the List entries box manually, and click Add 

button to insert your list to the Custom lists box. Note: You need type the list of values 

separated by Enter button or comma. See below.

 

2. If the values exist in current workbook, you can click the  button to select the cells and 

click Import button to import it to the Custom lists box. 
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 Click OK > OK to close the Excel Options dialog box. And your custom list has been created, so when 

you enter the first value of your list, and then drag the fill handle to the cell that you want to fill, your 

custom list values will be filled into the cells in order.  

 You can fill the values vertically or 

horizontally.  If you pull Fill Handle to the right 

and down directions, the data will be 

entered in an increasing order.  Pulling Fill 

Handle to the left or up directions will do the 

opposite. 

 

More examples of series that you can fill 

When you fill a series, the selections are extended as shown in the following table. In this table, items 

that are separated by commas are contained in individual adjacent cells on the worksheet. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Initial selection Extended series 

1, 2, 3 4, 5, 6,... 

9:00 10:00, 11:00, 12:00,... 

Mon Tue, Wed, Thu,... 

Monday Tuesday, Wednesday, Thursday,... 

Jan Feb, Mar, Apr,... 

Jan, Apr Jul, Oct, Jan,... 

Jan-07, Apr-07 Jul-07, Oct-07, Jan-08,... 

15-Jan, 15-Apr 15-Jul, 15-Oct,... 

2007, 2008 2009, 2010, 2011,... 

1-Jan, 1-Mar 1-May, 1-Jul, 1-Sep,... 

Qtr3 (or Q3 or Quarter3) Qtr4, Qtr1, Qtr2,... 

text1, textA text2, textA, text3, textA,... 

1st Period 2nd Period, 3rd Period,... 

Product 1 Product 2, Product 3,... 
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 Quick Auto Fill Option:  You can use the Quick Auto Fill button to change the 

data you just filled in.  This is especially useful for filling in data where you 

want to select between days, weeks, weekdays only, etc.  Let’s say you want 

to fill in weekdays only for a few rows of data after you fill in a date in a cell.   

1. Enter a date (1/2/15) in cell A1. 

2. Use Fill Handle to fill in with dates for the next 20 rows. 

Once you let go of Fill Handle, Excel will fill in 

automatic dates beginning with 1/3/15. However, what 

if you want to just fill in with weekdays not weekends? 

3. Hover your mouse on the Auto Fill Option command 

and click on the drop-down arrow next to it.  Clicking 

on the drop-down arrow should give you a choice to fill 

in weekdays only.   

4. Select that radio button and now the filled in dates will 

only include weekdays.  

 

 

 

Fill Command:  This command exists under the Home tab in the Editing 

group. You may also use this command to fill a range of cells with data.  This 

is especially useful to fill in series of date values with step values such as 

every 3 days, 7 days, etc.  For example, you wanted to fill every Monday 

beginning with a date 1/5/2015 for the entire year of 2015.  Let’s follow the 

step below. 

 Select cell B1. Type in 1/5/15 in that cell.  That is a Monday. 

 Select the entire column B. 

 Click on the Fill command and click on the drop-down arrow and 

select Series.  

 In the Series dialog box, change the Step value to 7 to indicate we want on a weekly basis and type 

in the Stop value as 12/31/15 to indicate that we want 

to fill only up to the end of the year. 

 Click on OK.  Your dates will only includes Mondays for 

the entire year until it stops on the last Monday 

12/28/15. 

 Note:  Even though you selected the entire columb B to 

fill in the data, having the stop value will let you stop at 

the last value, in this case, at a particular date 12/31/15. 
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Tables: 

Once you've entered information into a worksheet, you may want to format your data as a table.  Tables 

also include filtering by default. You can filter your data at any time using the drop-down arrows in the 

header cells as long as your data is arranged in columns with descriptive column headings.  You can use 

Excel’s predefined table styles to organize your content and make your data easier to use.  Let’s use the 

worksheet SortbyColor.  Make sure you clear all filters.  Let’s select columns G and H and Delete them.   

 

 Click anywhere within the data on your worksheet. 

 From the Home tab, click the Format as Table command in the 

Styles group.   Select a Table Style from the menu by 

clicking on one. You can change your Table Style later by 

hovering the mouse to another style.. 

OR 

 You can use Insert>Table command. 

 
 

 

 Format as Table or Create Table window will 

appear.  Excel indicates the cells to be included in 

the table setting with surrounding marching ants 

and the box to confirm “My table has headers” is 

already checked.  

 Click OK. 

 

 Each column header now has a drop-down 

arrow indicating a filter for each column.  If you 

have any missing column headings, Excel will 

just insert a general column# which you can 

overtype and replace later.  Now the data in 

this table can be filtered and un-filtered as if 

you had used the Filter command in the first place.   

 

When you create an Excel table, Excel assigns a name to the table.  In our case, Excel just assigned the 

generic name Table1.  Look under the Design tab in the Properties group under Table Name.  You may 

change the Table name as you like but your table name must not have spaces in between.  Creating a 

Table also provides names to each column in the table. When you add formulas to an Excel table, those 

names can appear automatically as you enter the formula and select the cell references in the table 
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instead of manually entering them.  That means instead of using the explicit cell references such as 

=E2*F2, Excel will use =Units*Unit Cost if you enter the formula and select the cell references in the table 

instead of manually entering them.  Let’s practice, adding a Total column back into our data sheet.  Select 

cell G1 and type the word “Total” and hit Enter.   

 

You can see Excel included the new column G into its Table reference. 

 

Now, enter a formula in cell G2 by selecting the cell references.   

 Type in = sign in G2. 

 Point and click cell E2 to include in your formula.  Excel enters the name of the column “Units” 

instead of the explicit cell reference E2.  

  

 Type in * sign to multiply. 

 Point and click cell F2 to include in your formula.  Again, Excel uses the name of the column “Unit 

Cost” in the formula.  

 

 Hit enter to complete your formula.  You will see that Excel automatically creates a calculated 

column and copies the formula down the entire column for you, adjusting it for each row. 

That combination of table and column names is called a structured reference. The names in structured 

references adjust whenever you add or remove data from the table.  Structured references also appear 

when you create a formula outside of an Excel table that references table data. The references can make it 

easier to locate tables in a large workbook. 

 

Adding Rows or Columns in Tables:  Excel allows you two ways to add rows or columns. 

1. Begin typing new content after the last row or column in the table. The row or column will be 

included in the table automatically.  If there is any formula in original table, it will be copied into 

the new cell automatically. 
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2. Click, hold, and drag the bottom-right corner Sizing Handle of the 

table to create additional rows or columns.  

 

 

 

Modifying Styles in Tables:  You can turn various 

options on or off under the Design tab to change the 

appearance of any table. There are six options: Header 

Row, Total Row, Banded Rows, First Column, Last 

Column, and Banded Columns.   You can see this option 

when you select any cell in your table.  

From the Design tab, check or uncheck the desired 

options in the Table Style Options group.   

 

To Remove a Table: Sometimes you may not want to use the additional features included with tables, such as 

the Sort and Filter drop-down arrows. You can remove a table from the workbook while still preserving the 

table's formatting elements, like font and cell color. To do that: 

 

 Select any cell in your table. The Design tab will appear. 

 Click the Convert to Range command in the Tools group.  

 A dialog box will appear. Click Yes. 

 

Introduction to Charts 

Charts allow you to illustrate your workbook data graphically, which makes it easy to visualize comparisons 

and trends.  Excel has several different types of charts, allowing you to choose the one that best fits your 

data. In order to use charts effectively, you'll need to understand how different charts are used.  They can 

be found under the Insert tab in the Charts group.  Recommended Charts will pick the most suitable chart 

for your data automatically.  However, you can select your own type.  Most frequently used charts are: 

 

Column Charts use vertical bars to represent data. They‘re 

most frequently used for comparing information. 

Line Charts are ideal for showing trends making it easy to 

see whether values are increasing or decreasing over time. 

Pie charts make it easy to compare proportions. Each 

value is shown as a slice of the pie, so it's easy to see which values make up the percentage of a whole. 

Bar charts work just like Column charts, but they use horizontal bars instead of vertical bars. 

Area charts are similar to line charts, except that the areas under the lines are filled in. 

Surface charts allow you to display data across a 3D landscape. They work best with large data sets, 

allowing you to see a variety of information at the same time. Source: GCFlearnfree.org 
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Let’s use ExcelPart6.xlsx and click on ChartTitle worksheet to practice this concept. 

 Click anywhere on the data to include everything on the worksheet. You can pick a specific range 

by selecting with your mouse 

as well. Be sure to include 

column titles and row labels. 

 Click on Insert tab and hover 

your mouse over a Column 

Chart type.  A column chart 

will be automatically placed in 

the same worksheet by 

default as shown below. For 

this example, click on 

Clustered Column under 2-D 

Column style. 

 Once the chart is on your 

sheet, you will notice that 

Chart Tools contextual toolbar is added on the ribbon.  And there are two tabs – Design and 

Format – associated with the toolbar. 

 

 
 

Design Tab:   

 Chart Styles: You can change your chart style to a different design by hovering your mouse over 

and preview your new style.  

 Switch Row/Column: You can 

switch the way charts group your 

data by switching the rows and 

columns so the chart will group 

the data by genre, with columns 

for each year. In both cases, the 

chart contains the same data—it's 

just organized differently.  

 Select Data: You can change to a 

different set of data even after you 

created a chart by using this 

function. 

 Change Chart Type: Use this to change your chart type to a different type.  
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 Move Chart: Once you are satisfied how your chart appears, you can use this command to move 

your chart to a new worksheet in the same workbook. 

 
 One can use chart formatting shortcut buttons to quickly add chart elements, change the chart 

style, and filter the chart data as well.

 
 



 

Copyright © 2020 ASCPL All Rights Reserved Page 10 of 14 MS2016-ExcelPart6 MMS 9/3/2020 
 

o Clicking on the Plus sign will let you include/exclude the chart 

elements such as legend, title, etc.  The same command can be found 

on under the Design Tab in the Chart Layout group at the beginning 

of the ribbon.   

o Clicking on the Brush 

sign will let you change 

the Style and Color of 

your chart.  

o Clicking on the Filter 

sign will let you filter the 

chart to only include the 

data set of your choice.  After checking or unchecking the boxes, 

click Apply button so that your chart will only display the data set of 

your choice.  

 

 

 

 

 

 

 

 

 

 

 

 

Format Tab:  Commands under this tab have more to do with changing the elements within the chart after 

you select those individual elements. For example, if you want to change the border color of the Title Box, 

click on the Title box first then hover the mouse on a different Shape Style to view the different color 

border style.   
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Let’s try another type of chart by using the Grocery worksheet in the 

same workbook. You want to know how much % of the grocery budget 

is spent on what category.  First, you want to find the subtotals of each 

category. 

 Click anywhere inside the data. 

 Click on Data>Subtotal. 

 Select Sum for function and check Total Cost to subtotal on it. 

 Click on OK. 

 Click on Level 2 on top left corner to hide detailed rows for 

each category.  Your spreadsheet should only have two 

columns with data in it – Column A for Category and Column F 

for Total Cost.  

 Hold down the Control button on your keyboard and select 

Cells A1:A37 and F1:F37 as it appears in the picture shown. 

 

 Click on Insert Tab and select the 3-D Pie 

from the Charts group.  You will get a pie 

chart that is suitable to show the 

proportions of a whole. 
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 Let’s enhance the chart by clicking on the Plus sign next to the chart to format Data Labels. Check 

Chart Title and Data Labels and uncheck the Legend.  

 Click on Data Labels arrow and click on More Options from the list. 

 

 

 

 

 

 On the right Format Data 

Labels pane, check boxes for 

Category Name, Percentage, 

and Show Leader Lines.   

 Your enhanced Pie 

Chart now has better 

labels to indicate how 

much percentage of 

your grocery money is 

spent on each category. 

 

 

 

 

 

 

Sparklines 

Sparklines are miniature charts that fit into a single cell.  Use Sparklines to analyze and view trends in your 

data without creating an entire chart.  Sparklines have certain advantages over charts. If you have many 

rows of data, a traditional chart would not be appropriate to represent all of the rows, making relevant 

data difficult to find. But if you placed a sparkline on each row, it will be right next to its source data, 

making it easy to see relationships and trends for multiple data series at the same time. 

 

There are three types of Sparklines:  

o Line 

o Column 

o Win/Loss 

 

Line and Column work the same as line and column charts. Win/Loss is similar to Column, except it only 

shows whether each value is positive or negative instead of how high or low the values are. All three types 

can display markers at important points, such as the highest and lowest points, to make them easier to 

read. 
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To create Sparklines: 

 

Generally, you will have one sparkline for each row, but you can create as many as you want in any 

location. Just like formulas, it's usually easiest to create a single sparkline and then use the fill handle to 

create sparklines for the adjacent rows. In our example, we'll create sparklines to help visualize trends in 

sales over time for each salesperson.  

 

Let’s use SparkLines worksheet in the same workbook ExcelPart6.xlsx to practice.  Source: GCFlearnfree.org 

 Select the cells that will serve as the source data for the first sparkline. In our example, we'll select 

the cell range B3:G3. 

 Click on Insert tab and Line in the Sparklines group as shown.  

 

 

 

 

 

 

 Create Sparklines dialog box will appear.  

Use the mouse to select the cell where the 

sparkline will appear, then click OK. In our 

example, we'll select cell H3, and the cell 

reference will appear in the Location Range: 

field.  The sparkline will appear in the 

specified cell: H3.  

 

 

 

 

 

 

 Use Fill Handle to extend the sparklines to the 

rows below to see the trends on other sales data. 

Now the sparklines show clear trends in sales 

over time for each salesperson in our worksheet.  

Make the row height bigger to see the sparklines 

more prominent. 
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To Modify Sparklines: 

Once you click on any cell that has sparklines, notice the Sparklines Toolbar appear on the ribbon with the 

Design tab. 

 
 

Here you can change: the sparkline type (Line, Column, Win/Loss), see high/low point markers, change 

color of sparklines and even marker color by using the commands.  

 In our example, let’s select the sparkline in cell H3 and click on High Point and Low Point check 

boxes in the Show group. 

 Select a different style that shows the green dot for the high point and the red dot 

for the low point to stand out.   

 

 Let’s change the sparkline type to Column by checking the Column 

from Type group.  

 

 

 Notice all the high column bars look the same even though the 

figures are not exactly the same.  To counter this drawback of the 

sparkline feature, click on the drop-down arrow under the Axis 

command.   

 

 

 

 

 Notice both minimum and maximum values are “Automatic” for 

sparklines.  Change both to set as “Same for All Sparklines”.  

Now your sparklines should reflect the actual data on your 

spreadsheet. 

 

 

 

 

 

 

 

 

 

 

 

 


