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Microsoft Excel 2016: Part 7  

Comments, Reviews  

and Finalizing Your Workbook 

 

 

 

Comments:  
Excel allows you to provide the feedback for a particular cell instead of editing the cell content.  Let’s 

use the Practice worksheet in the ExcelPart7.xlsx workbook. 

 

 Select the cell where you want the comment to appear. In our example, we'll select cell I2. 

 From the Review tab, click the New 

Comment command.  

 

 

 

 

 A comment box will appear. Type your 

comment, then click anywhere outside 

the box to close the comment.  

 The comment will be added to the cell, 

represented by the red triangle in the 

top-right corner.  The comment box 

will stay as long as Show All 

Comments command is selected in the 

Comments group on the ribbon.  You 

can hide the comments box by clicking 

on Show All Comments.  By doing so, 

only the red triangle indicator will be 

there and once you hover the mouse 

over the cell, the comment box will 

display.  

 

Editing comments: You can edit the content of the comment by clicking inside the comment box or 

using Edit Comment command on the ribbon after you select the cell that contains the comments. 

 

Deleting comments: Select the cell containing the comment you wish to delete.  From the Review 

tab, click the Delete command in the Comments group.  The comment will be deleted. 
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Finalizing and Protecting your Workbook: 

It is a good idea to check your workbook before sharing that it does not include spelling errors or 

information you wish to keep private.  You can use Spell Check and Document Inspector to assure 

avoiding these errors.  We will use the same worksheet Practice. 

 

Check Spelling Errors:   

 From the Review tab, click the Spelling command. 

 
 

 The Spelling dialog box will appear. For each spelling error in your worksheet, Spell Check 

offers suggestions for the correct spelling. Choose a suggestion or ignore if does not need to 

be corrected, then click Change to 

correct the error or Ignore Once to 

skip the word without changing it.  

Ignore All will skip the word 

without changing it and also skip all 

other instances of the word in your 

worksheet.  Change All will change 

the current word and all other 

instances of the word. One can also 

add any word to the Dictionary by 

using the Add to Dictionary 

command so that Word will not 

prompt the word as an error in future. 

 

 

 A dialog box will appear after reviewing all 

spelling errors. Click OK to close Spell 

Check. 
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Protecting your Workbook: 

Protecting your workbook becomes essential once it is shared among multiple users so that 

someone cannot delete or change data in certain cells by accident.  Nor can they insert/delete 

columns, among other things.  To prevent anyone from changing, moving, or deleting important 

data, you can protect certain worksheet or workbook elements.  Use the next worksheet 

ProtectWork. 

 Click on File and from the Info pane click on the drop-down arrow next to Protect 

Workbook. 

 

 
 

 Mark as Final: Use this to discourage others from editing the workbook.  Workbook will be 

opened as Read-Only copy for others.  However, it will not prevent them from editing or 

deleting contents had they chosen Edit Anyway command upon opening. 
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 Encrypt with Password:  It is simple but effective.  Without the password, one cannot open 

the workbook.  Passwords are case sensitive.  Two ways to set your password. 

 

1. Click on Encrypt with Password and fill 

in the password when Encrypt 

Document window pops up.  

OR 

 

 

 

 

 

2. Click on File>Save As.  Select a location you want to save your workbook.  When the 

Save As dialog box comes up, click on the drop-down arrow on the Tools button 

next to the Save button.  Select General Options.  General Options dialog box will 

come up.   

 Enter password in the Password to open box.  This will prevent users 

without password from opening the workbook just like in the first option 

above. 

 If you want some users to be able to modify the workbook upon opening, 

enter another password in the Password to modify box.  Those who have 

the modification password will only be able to modify.  The others will be 

forced to work with the Read-only copy.  Read-only copy users will only be 

allowed to save as a copy if they make any changes and try to save. 

 

 

 

 

 

 

 

 

 

 

To unprotect workbook with passwords: you will have to go through above steps and delete 

passwords from boxes in General Options box. 
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 Protect current Sheet:  This feature is 

especially useful if you want users to be 

able to have access to some parts of 

the worksheet yet still want to protect 

other parts that contain formulas, for 

example.  You can get to this command 

either under Info pane (under Protect 

Workbook>Protect Current Sheet) or via the Review tab.  Let’s assume we want to allow 

users to enter/modify data in cells B2:G18 but want to protect the remaining cells on sheet.   

By default, every cell in a worksheet is automatically locked but it does not mean these cells 

are protected.  You must use Protect Sheet command to do so.  Follow the steps below. 

 

1. Select the cell range B2:G18.   

2. Under the Home tab, in the Cells group, click the drop-down arrow 

next to the format.    

 

 

3. From the menu, under the Protection heading, click on 

Lock Cell.  By doing so, you are unlocking the cells 

range B2:G18 – this action will enable the users to 

edit/modify data in that range.  

 

 

 

4. Go to Review, click on the Protect Sheet.  

From the dialog box, enter the password (so 

no one can unprotect without the password) 

and make sure to leave the check box for only 

Select the unlocked cells under allow all users 

of this worksheet to.  One other option you 

may consider leaving the check box on is for 

Edit objects further down in the list.  Giving 

this option will let the user to be able to leave 

comments.   
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To Unprotect Sheet:  Right-click on the worksheet tab; then click on 

Unprotect Sheet command.  Enter the password when prompted.  

 

 

 

 

  

 

 

 Protect Workbook:  This command is used to keep others from structural changes such as 

moving, deleting or adding sheets.  To apply this rule, you can use either method below. 

1. click on the Review tab. Then click on the Protect Workbook.  OR 

2. Click on File>Info>Protect workbook>Protect workbook structure 

Protect Structure and Windows dialog box will show up and the box for Structure will 

automatically be checked.  Even though Password is optional, it is recommended to 

enter so no one can unprotect the workbook without the password. 
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Doing so will deactivate all commands upon right-clicking on the sheet 

and no one will be able to insert, delete, rename sheets, etc.  

 

 

 

 

 

To unprotect workbook, click on the Protect Workbook command one 

more time again; enter the password to unprotect it. 
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Exercise 4-7: 
1. Open a new blank worksheet by clicking on the + sign in the same workbook. 

2. In Cell B1: type “Name” set Calibri size 20. Bold type and Font Color Green. 

3. In Cell B2: type “Family Budget”; set Calibri size 31. Bold type and Font Color Blue. 

4. Change column width to 4 on Column A. 

5. Change column width to 43 on Column B. 

6. Change the height of row 2 to 45.  

7. In Cell B3: type the current month such as “March”. Set bold type and font to size 20 and 

Font Color Green. 

8. Select Cell B3 again.  Apply in that cell, thick bottom border. 

9. In Cell B4: set the cell to “Text” format; type the current year such as “2020”. Set bold type 

and font to size 20 and Font Color Grey. 

10. Change Rows 3 and 4 heights to 27. 

11. Name this worksheet as “Cash Flow”.   

12. Make a copy of this worksheet twice in the same workbook to show at the end of workbook.  

You will see “Cash Flow (2)” and “Cash Flow (3)”.   

13. Rename “Cash Flow (2) as “Monthly Income”.  Change the color of worksheet to Green. 

14. Rename “Cash Flow (3) as “Monthly Expense”.  Change the color of worksheet to Orange. 

15. Change the color of “Cash Flow” worksheet to Blue. 

16. Select the Monthly Income worksheet.  You are going to copy a set of data from another 

source instead of typing in. 

17. Open up the workbook called “DataforExcelPart7Exercise.xlsx” and copy the data A1:D5 from 

Data1 sheet on Cell B5 into the Monthly Income sheet.  Your worksheet should look as shown 

below. 

 
18. Apply the format of Cell B1 to Cell B5 by using the format painter. 

19. Change column widths of C through E to size 17. 

20. Select Cells B5:E9; Click on Insert and select Table to change this range of cells into a table. 
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21. In cells C9 and D9, find the total of those columns by using the Summation function on Home 

tab.  Since we are in a table, notice the =SUBTOTAL formula is automatically created, which 

provides the same result as =SUM formula. 

22. In Cell E6, find the Actual-Projected value (=D6-C6).  Since we are in a table range, upon 

clicking cells D6 and C6 will give us the formula =[@Actual]-[@Projected]. 

23. And the remaining cells in Column E should also filled in automatically. 

24. Select the Monthly Expense worksheet.  You are going to copy a set of data from 

“DataforExcelPart7Exercise.xlsx” from Data2 sheet into this. 

25. Go to “DataforExcelPart7Exercise.xlsx” – Data2 sheet.  Select A1:D22; copy and paste the 

data in Monthly Expense worksheet on Cell B5. 

26. Apply the format of Cell B1 to Cell B5 by using the format painter. 

27. Select Cells B5:E26; Click on Insert and select Table to change this range of cells into a table. 

28. Change column widths of C through E to size 17. 

29. In cells C26 and D26, find the total of those columns by using the Summation function on 

Home tab.  Since we are in a table, notice the =SUBTOTAL formula is automatically created, 

which provides the same result as =SUM formula. 

30. In Cell E6, find the Actual-Projected value (=D6-C6).  Since we are in a table range, upon 

clicking cells D6 and C6 will give us the formula =[@Actual]-[@Projected]. 

31. And the remaining cells in Column E should also filled in automatically. 

32. Select the Cash Flow worksheet.  You are going to copy a set of data from 

“DataforExcelPart7Exercise.xlsx” from Data3 sheet into this. 

33. Go to “DataforExcelPart7Exercise.xlsx” – Data3 sheet.  Select A1:D4; copy and paste the data 

in Cash Flow worksheet on Cell B5. 

34. Apply the format of Cell B1 to Cell B5 by using the format painter. 

35. Let’s take care of Projected Column – column C in this worksheet. Link Cell C6 to Cell C9 from 

projected column in Monthly Income.  Note, the linking or cell reference is a formula; it 

begins with an equal sign in a cell where you want to see the result.  Since we want to see the 

result in Cell C6, we will begin typing he “=” sign in Cell C6; then click on Monthly Income 

worksheet and in there, click on Cell C9; hit Enter.  You should be back at cell C6 on your Cash 

Flow sheet. (the formula should look ='Monthly Income'!C9) 

36. Similarly, link Cell C7 to Cell C26 from projected column in Monthly Expense. (the formula 

should look ='Monthly Expense'!C26) 

37. Now, let’s link the cells for column D – Actual column.  Link cell D6 to cell D9 from actual 

column in Monthly Income.  (the formula should look ='Monthly Income'!D9) 

38. Do the same to link cell D7 to Cell D26 from actual column in Monthly Expense. (the formula 

should read ='Monthly Expense'!D26) 

39. Select Cells B5:E8; Click on Insert and select Table to change this range of cells into a table. 

40. In Cell C8, find the total cash in projected column. =C6-C7 

41. In Cell D8, find the total cash in Actual column. =D6-D7 

42. In Cell E6, find the difference of Actual-Projected column. =D6-C6. Upon hitting enter to finish 

this cell, the remaining cells in column E should be automatically completed.   

43. Use Cells range B5:D8 to draw a bar chart.  Retitle the chart and change legend location and 

insert labels so your chart will look like the one shown on next page.  
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44. Finally, select all three worksheets; select Cell B1 then type in your family last name so every 

cell B1 in all three sheets would have same information. 
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